GitHub Advisoryadvisory · PyPI

GHSA-287q-jfcp-9vhv django-photologue vulnerable to Cross-site Scripting

MEDIUM Published 2022-12-15 Modified 2024-09-16 Official page ↗
Aliases
CVE-2022-4526
Ecosystem
PyPI
Packages
django-photologue
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-12-15

Affected packages

• PyPI django-photologue: < 3.16 → fixed in 3.16

Description

A vulnerability was found in django-photologue up to 3.15.1 and classified as problematic. Affected by this issue is some unknown functionality of the file photologue/templates/photologue/photo_detail.html of the component Default Template Handler. The manipulation of the argument object.caption leads to cross site scripting. The attack may be launched remotely. Upgrading to version 3.16 is able to address this issue. The name of the patch is 960cb060ce5e2964e6d716ff787c72fc18a371e7. It is recommended to apply a patch to fix this issue. VDB-215906 is the identifier assigned to this vulnerability.

Related

Alias · CVE (1)

  • CVE-2022-4526 A vulnerability was found in django-photologue up to 3.15.1 and classified as problematic. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References