GitHub Advisoryadvisory · Maven
GHSA-292x-hjr8-226f Cloud Foundry UAA Privilege Escalation
HIGH
Official page ↗
- Aliases
- CVE-2018-15761
- Ecosystem
- Maven
- Packages
- org.cloudfoundry.identity:cloudfoundry-identity-server
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Reviewed
- 2024-03-01
Affected packages
• Maven org.cloudfoundry.identity:cloudfoundry-identity-server: < 4.23.0 → fixed in 4.23.0
Description
Cloud Foundry UAA release, versions prior to v64.0, and UAA, versions prior to 4.23.0, contains a validation error which allows for privilege escalation. A remote authenticated user may modify the url and content of a consent page to gain a token with arbitrary scopes that escalates their privileges.
Related
Alias · CVE (1)
- CVE-2018-15761 Cloud Foundry UAA release, versions prior to v64.0, and UAA, versions prior to 4.23.0, contains a validation error which allows for… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-15761 advisory
- https://github.com/cloudfoundry/uaa/commit/3f0730a015d10166de23b7e036743c185f0576a6 web
- https://github.com/cloudfoundry/uaa/commit/95b7d9e7fae534a362b98de1df5bf501cd52c481 web
- https://github.com/cloudfoundry/uaa package
- https://www.cloudfoundry.org/blog/cve-2018-15761 web