GitHub Advisoryadvisory · crates.io

GHSA-29mf-62xx-28jq buffered-reader vulnerable to out-of-bounds array access leading to panic

LOW Published 2023-06-06 Modified 2025-07-28 Official page ↗
Aliases
CVE-2023-53161
Ecosystem
crates.io
Packages
buffered-reader
Severity
Low
CVSS vector
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Reviewed
2023-06-06

Affected packages

• crates.io buffered-reader: < 1.0.2 → fixed in 1.0.2 • crates.io buffered-reader: >= 1.1.0, < 1.1.5 → fixed in 1.1.5

Description

Affected versions of the crate have a bug where attacker-controlled input can result in the use of an out-of-bound array index. Rust detects the use of the out-of-bound index and causes the application to panic. An attacker may be able to use this to cause a denial-of-service. However, it is not possible for an attacker to read from or write to the application's address space.

Related

Alias · CVE (1)

  • CVE-2023-53161 The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic. vulnerability

References