GitHub Advisoryadvisory · PyPI
GHSA-2c7w-v459-cwgf MotionEye allows attackers to access sensitive information
HIGH
Official page ↗
- Aliases
- CVE-2022-25568
- Ecosystem
- PyPI
- Packages
- motioneye
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2024-11-22
Affected packages
• PyPI motioneye: < 0.43.1b1 → fixed in 0.43.1b1
Description
MotionEye v0.42.1 and below allows attackers to access sensitive information via a GET request to /config/list. To exploit this vulnerability, a regular user password must be unconfigured.
Related
Alias · CVE (1)
- CVE-2022-25568 MotionEye v0.42.1 and below allows attackers to access sensitive information via a GET request to /config/list. vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-25568 advisory
- https://github.com/ccrisan/motioneye/issues/2292 web
- https://github.com/motioneye-project/motioneye/commit/c60b64af5bb8c09189071522a1f6796cb44340b0 web
- https://github.com/motioneye-project/motioneye package
- https://github.com/pypa/advisory-database/tree/main/vulns/motioneye/PYSEC-2022-43141.yaml web
- https://www.pizzapower.me/2022/02/17/motioneye-config-info-disclosure web