GitHub Advisoryadvisory · RubyGems
GHSA-2cj2-qqxj-5m3r Phusion Passenger denial of service
MEDIUM
Official page ↗
- Aliases
- CVE-2025-26803
- Ecosystem
- RubyGems
- Packages
- passenger
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-908
- Reviewed
- 2025-02-24
Affected packages
• RubyGems passenger: >= 6.0.21, < 6.0.26 → fixed in 6.0.26
Description
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
Related
Alias · CVE (1)
- CVE-2025-26803 The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an… vulnerability
Weakness · CWE (1)
- CWE-908 Use of Uninitialized Resource weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-26803 advisory
- https://github.com/phusion/passenger/commit/bb15591646687064ab2d578d5f9660b2a4168017 web
- https://blog.phusion.nl/2025/02/19/passenger-6-0-26 web
- https://github.com/phusion/passenger package
- https://github.com/phusion/passenger/compare/release-6.0.25...release-6.0.26 web
- https://github.com/phusion/passenger/releases/tag/release-6.0.26 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/passenger/CVE-2025-26803.yml web
- https://www.phusionpassenger.com/support web