GitHub Advisoryadvisory · Packagist

GHSA-2f25-pfq3-c7h8 Phpseclib needs guardrails on large binaryfield integers

HIGH Published 2026-05-08 Modified 2026-05-08 Official page ↗
Aliases
CVE-2023-49316
Ecosystem
Packagist
Packages
phpseclib/phpseclib
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400, CWE-834
Reviewed
2026-05-08

Affected packages

• Packagist phpseclib/phpseclib: >= 3.0.0, < 3.0.34 → fixed in 3.0.34

Description

Related

Alias · CVE (1)

  • CVE-2023-49316 In Math/BinaryField.php in phpseclib 3 before 3.0.34, excessively large degrees can lead to a denial of service. vulnerability

Weakness · CWE (2)

  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-834 Excessive Iteration weakness

References