GitHub Advisoryadvisory · Packagist

GHSA-2f28-69j7-85hf Easy!Appointments SQL injection vulnerability

MEDIUM Published 2025-08-26 Modified 2025-08-26 Official page ↗
Aliases
CVE-2025-50383
Ecosystem
Packagist
Packages
alextselegidis/easyappointments
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P
Weaknesses
CWE-89
Reviewed
2025-08-26

Affected packages

• Packagist alextselegidis/easyappointments: < 1.5.2-beta.1 → fixed in 1.5.2-beta.1

Description

alextselegidis Easy!Appointments v1.5.1 was discovered to contain a SQL injection vulnerability via the order_by parameter.

Related

Alias · CVE (1)

  • CVE-2025-50383 alextselegidis Easy!Appointments v1.5.1 was discovered to contain a SQL injection vulnerability via the order_by parameter. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References