GitHub Advisoryadvisory · Packagist
GHSA-2f4r-34m4-3w8q Auth0 Wordpress plugin Vulnerable to Brute Force Authentication Tags of CookieStore Sessions
CRITICAL
Official page ↗
- Ecosystem
- Packagist
- Packages
- auth0/wordpress
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-287
- Reviewed
- 2025-05-17
Affected packages
• Packagist auth0/wordpress: < 5.3.0 → fixed in 5.3.0
Description
Overview
Session cookies of applications using the Auth0 Wordpress plugin configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access.
Am I Affected?
You are affected by this vulnerability if you meet the following pre-conditions:
1. Applications using the Auth0 WordPress Plugin with version <=5.2.1
2. Auth0 WordPress Plugin uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0.
3. Session storage configured with CookieStore.
Fix
Upgrade Auth0/wordpress plugin to v5.3.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected.
Acknowledgement
Okta would like to thank Félix Charette for discovering this vulnerability.
Related
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://github.com/auth0/wordpress/security/advisories/GHSA-2f4r-34m4-3w8q web
- https://nvd.nist.gov/vuln/detail/CVE-2025-47275 advisory
- https://github.com/auth0/wordpress/commit/06b64468089472d8b62c881708be7eb3749b35ac web
- https://github.com/auth0/wordpress package
- https://github.com/auth0/wordpress/releases/tag/5.3.0 web