GitHub Advisoryadvisory · Packagist

GHSA-2ff6-837j-hg5x Magento OS Command ('OS Command Injection') vulnerability

HIGH Published 2024-08-14 Modified 2025-11-06 Official page ↗
Aliases
CVE-2024-39402
Ecosystem
Packagist
Packages
magento/project-community-edition, magento/community-edition
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-78
Reviewed
2025-11-06

Affected packages

• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet) • Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p2 → fixed in 2.4.7-p2 • Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p7 → fixed in 2.4.6-p7 • Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p9 → fixed in 2.4.5-p9 • Packagist magento/community-edition: >= 2.4.4-p1, < 2.4.4-p10 → fixed in 2.4.4-p10 • Packagist magento/community-edition: 2.4.7 (no fix yet) • Packagist magento/community-edition: 2.4.6 (no fix yet) • Packagist magento/community-edition: 2.4.5 (no fix yet) • Packagist magento/community-edition: 2.4.4 (no fix yet)

Description

Magento versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead in arbitrary code execution by an admin attacker. Exploitation of this issue requires user interaction and scope is changed.

Related

Alias · CVE (1)

  • CVE-2024-39402 Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Neutralization of Special Elements… vulnerability

Weakness · CWE (1)

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References