GitHub Advisoryadvisory · Maven
GHSA-2gh6-wc3m-g37f hermes-management is vulnerable to RCE due to Apache commons-jxpath
CRITICAL
Official page ↗
- Ecosystem
- Maven
- Packages
- pl.allegro.tech.hermes:hermes-management
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-1395
- Reviewed
- 2024-09-17
Affected packages
• Maven pl.allegro.tech.hermes:hermes-management: >= 0.8.2, < 2.2.9 → fixed in 2.2.9
Description
Impact
hermes-management is vulnerable to RCE when it processes user-controlled data due to using Apache commons-jxpath.
Patches
Upgrade Hermes to at least hermes-2.2.9
References
https://hackinglab.cz/en/blog/remote-code-execution-in-jxpath-library-cve-2022-41852/
Related
Weakness · CWE (1)
- CWE-1395 Dependency on Vulnerable Third-Party Component weakness
References
- https://github.com/allegro/hermes/security/advisories/GHSA-2gh6-wc3m-g37f web
- https://github.com/allegro/hermes/commit/72ecc5aa41e37fd614443dd35d9200b66a61afb1 web
- https://github.com/allegro/hermes/commit/92d4ad0cf6868ba784707772b78e129fedff7a31 web
- https://github.com/allegro/hermes package
- https://hackinglab.cz/en/blog/remote-code-execution-in-jxpath-library-cve-2022-41852 web