GitHub Advisoryadvisory · Maven
GHSA-2gw6-73wc-x88f Apache Geode information disclosure vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2017-5649
- Ecosystem
- Maven
- Packages
- org.apache.geode:geode-core
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2022-11-08
Affected packages
• Maven org.apache.geode:geode-core: >= 1.1.0, < 1.1.1 → fixed in 1.1.1
Description
Apache Geode before 1.1.1, when a cluster has enabled security by setting the security-manager property, allows remote authenticated users with CLUSTER:READ but not DATA:READ permission to access the data browser page in Pulse and consequently execute an OQL query that exposes data stored in the cluster.
Related
Alias · CVE (1)
- CVE-2017-5649 Apache Geode before 1.1.1, when a cluster has enabled security by setting the security-manager property, allows remote authenticated users… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness