GitHub Advisoryadvisory · npm

GHSA-2gx6-7gx2-wwcf Ghost: Cross-Site Scripting in Universal Import

MEDIUM Published 2026-08-04 Modified 2026-08-04 Official page ↗
Aliases
CVE-2026-70588
Ecosystem
npm
Packages
ghost
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:L
Weaknesses
CWE-79
Reviewed
2026-08-04

Affected packages

• npm ghost: >= 5.26.0, < 6.54.1 → fixed in 6.54.1

Description

Impact The Universal Import feature in Ghost Admin failed to properly sanitize imported content resulting in XSS in post content. Vulnerable versions This vulnerability is present in Ghost from v5.26.0 up to v6.54.0. Patches v6.54.1 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. Workarounds If upgrading immediately is not possible, avoid using the Universal Import feature. References Ghost thanks meifukun for disclosing this vulnerability responsibly. For more information If you have any questions or comments about this advisory, email us at [email protected].

Related

Alias · CVE (1)

  • CVE-2026-70588 Ghost is a Node.js content management system. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References