GitHub Advisoryadvisory · Packagist

GHSA-2h23-c973-x63q phpMyAdmin Cross-site Scripting vulnerability

LOW Published 2022-05-17 Modified 2025-04-12 Official page ↗
Aliases
CVE-2011-4782
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U
Weaknesses
CWE-79
Reviewed
2025-04-12

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 3.4.0, < 3.4.9 → fixed in 3.4.9

Description

Cross-site scripting (XSS) vulnerability in libraries/config/ConfigFile.class.php in the setup interface in phpMyAdmin 3.4.x before 3.4.9 allows remote attackers to inject arbitrary web script or HTML via the host parameter.

Related

Alias · CVE (1)

  • CVE-2011-4782 Cross-site scripting (XSS) vulnerability in libraries/config/ConfigFile.class.php in the setup interface in phpMyAdmin 3.4.x before 3.4.9… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References