GitHub Advisoryadvisory · Packagist
GHSA-2hmm-q272-xmhf Moodle remote code execution
CRITICAL
Official page ↗
- Aliases
- CVE-2022-40314
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: < 3.9.17 → fixed in 3.9.17
• Packagist moodle/moodle: >= 3.11, < 3.11.10 → fixed in 3.11.10
• Packagist moodle/moodle: >= 4.0, < 4.0.4 → fixed in 4.0.4
Description
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
Related
Alias · CVE (1)
- CVE-2022-40314 A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness