GitHub Advisoryadvisory · crates.io

GHSA-2j3p-gqw5-g59j theshit's Improper Privilege Dropping Allows Local Privilege Escalation via Command Re-execution

HIGH Published 2026-03-02 Modified 2026-03-02 Official page ↗
Aliases
CVE-2026-21882
Ecosystem
crates.io
Packages
theshit
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-250, CWE-269, CWE-273
Reviewed
2026-03-02

Affected packages

• crates.io theshit: < 0.2.0 → fixed in 0.2.0

Description

Impact Vulnerability Type: Local Privilege Escalation (LPE) / Improper Privilege Management / Arbitrary Command Execution. The application automatically re-executes the previously failed command but does not properly drop elevated privileges during this process. When the tool is executed with `sudo` or otherwise runs with an effective UID of root, it records the last executed command and attempts to rerun it. However, the application fails to restore the original unprivileged user context before re-executing the command. As a result, the retried command is executed with root privileges, even if the original command was issued by an unprivileged user. This allows a local attacker to intentionally trigger a failed command under elevated execution and gain arbitrary command execution as root via the retry mechanism. Who is impacted: Any system where this tool is executed with elevated privileges is affected. The risk is especially high in environments where the tool is permitted to run via `sudo`, including configurations with `NOPASSWD`, as an unprivileged user can escalate privileges to root without additional interaction. Proof of Concept To verify the vulnerability without a shell, attempt to create a file in a root-protected directory. 1. Verify the file does not exist ```bash sudo ls /root/proof_of_lpe Output: No such file or directory ``` 2. Run the vulnerable command ```bash sudo bash -c "SH_PREV_CMD='touch /root/proof_of_lpe' target/release/theshit fix" ``` 3. Check if the file was created by root ```bash sudo ls -l /root/proof_of_lpe ``` Expected Result: The command succeeds silently, and the file `/root/proof_of_lpe` is created, confirming arbitrary command execution with root privileges. Patches The issue has been fixed in version 0.1.2. The patch ensures that privilege levels are correctly handled during command re-execution. Before retrying any previously executed command, the application now explicitly resets the effective UID and GID to the original invoking user. Workarounds If upgrading is not possible, users should avoid executing the application with `sudo` or as the root user. As a temporary mitigation, administrators should restrict the use of the tool in privileged contexts and ensure it is not included in `sudoers` configurations, particularly with `NOPASSWD`. Running the tool strictly as an unprivileged user prevents exploitation of the retry mechanism. References • Commit fixing the issue • CWE-269: Improper Privilege Management • CWE-273: Improper Check for Dropped Privileges • CWE-250: Execution with Unnecessary Privileges

Related

Alias · CVE (1)

  • CVE-2026-21882 theshit is a command-line utility that automatically detects and fixes common mistakes in shell commands. vulnerability

Weakness · CWE (3)

  • CWE-250 Execution with Unnecessary Privileges weakness
  • CWE-269 Improper Privilege Management weakness
  • CWE-273 Improper Check for Dropped Privileges weakness

References