GitHub Advisoryadvisory · Maven

GHSA-2j4h-cjgh-659v Reflected XSS vulnerability in Jenkins VncViewer Plugin

MEDIUM Published 2022-05-24 Modified 2022-12-29 Official page ↗
Aliases
CVE-2020-2207
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:vncviewer
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-12-29

Affected packages

• Maven org.jenkins-ci.plugins:vncviewer: < 1.8 → fixed in 1.8

Description

VncViewer Plugin 1.7 and earlier does not escape a parameter value in the `checkVncServ` form validation endpoint output. This results in a reflected cross-site scripting (XSS) vulnerability. VncViewer Plugin 1.8 escapes the parameter value in the output.

Related

Alias · CVE (1)

  • CVE-2020-2207 Jenkins VncViewer Plugin 1.7 and earlier does not escape a parameter value in the checkVncServ form validation endpoint, resulting in a… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References