GitHub Advisoryadvisory · Maven

GHSA-2j4q-9fff-236j Apache Struts XSS Vulnerability

MEDIUM Published 2022-05-17 Modified 2023-11-07 Official page ↗
Aliases
CVE-2016-2162
Ecosystem
Maven
Packages
org.apache.struts:struts2-core
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-07-31

Affected packages

• Maven org.apache.struts:struts2-core: >= 2.0.0, < 2.3.28 → fixed in 2.3.28

Description

Apache Struts 2.x before 2.3.28 does not sanitize text in the Locale object constructed by I18NInterceptor, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via unspecified vectors involving language display.

Related

Alias · CVE (1)

  • CVE-2016-2162 Apache Struts 2.x before 2.3.25 does not sanitize text in the Locale object constructed by I18NInterceptor, which might allow remote… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References