GitHub Advisoryadvisory · Packagist
GHSA-2j6v-829g-885q Magento Improper Access Control
MEDIUM
Official page ↗
- Aliases
- CVE-2021-21020
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-284
- Reviewed
- 2024-01-10
Affected packages
• Packagist magento/community-edition: < 2.3.6 → fixed in 2.3.6
• Packagist magento/community-edition: >= 2.4.0, < 2.4.1-p1 → fixed in 2.4.1-p1
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to an access control bypass vulnerability in the Login as Customer module. Successful exploitation could lead to unauthorized access to restricted resources.
Related
Alias · CVE (1)
- CVE-2021-21020 Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to an access control bypass… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness