GitHub Advisoryadvisory · PyPI

GHSA-2j76-26qq-7rvv MoinMoin cross-site scripting (XSS) vulnerability

MEDIUM Published 2022-05-17 Modified 2024-09-26 Official page ↗
Aliases
CVE-2010-2969
Ecosystem
PyPI
Packages
moin
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-02-08

Affected packages

• PyPI moin: <= 1.7.3 (no fix yet) • PyPI moin: >= 1.9.0, < 1.9.3 → fixed in 1.9.3

Description

Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.7.3 and earlier, and 1.9.x before 1.9.3, allow remote attackers to inject arbitrary web script or HTML via crafted content, related to (1) action/LikePages.py, (2) action/chart.py, and (3) action/userprofile.py, a similar issue to CVE-2010-2487.

Related

Alias · CVE (1)

  • CVE-2010-2969 Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.7.3 and earlier, and 1.9.x before 1.9.3, allow remote attackers to inject… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References