GitHub Advisoryadvisory · PyPI
GHSA-2jc8-4r6g-282j python-gnupg's shell_quote function does not properly escape characters
HIGH
Official page ↗
- Aliases
- CVE-2014-1928
- Ecosystem
- PyPI
- Packages
- python-gnupg
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2020-06-16
Affected packages
• PyPI python-gnupg: >= 0.3.5, < 0.3.6 → fixed in 0.3.6
Description
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "\" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
Related
Alias · CVE (1)
- CVE-2014-1928 The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-1928 advisory
- https://code.google.com/p/python-gnupg package
- https://code.google.com/p/python-gnupg/issues/detail?id=98 web
- https://github.com/advisories/GHSA-2jc8-4r6g-282j advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/python-gnupg/PYSEC-2014-91.yaml web
- http://seclists.org/oss-sec/2014/q1/246 web
- http://seclists.org/oss-sec/2014/q1/294 web
- http://www.debian.org/security/2014/dsa-2946 web