GitHub Advisoryadvisory · Packagist

GHSA-2jcw-r79x-4r5v Moodle does not set the RISK_XSS bit for graders

LOW Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2015-0216
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
Weaknesses
CWE-79
Reviewed
2024-01-25

Affected packages

• Packagist moodle/moodle: >= 2.8.0, < 2.8.2 → fixed in 2.8.2

Description

access.php in the Lesson module in Moodle 2.8.x before 2.8.2 does not set the RISK_XSS bit for graders, which allows remote authenticated users to conduct cross-site scripting (XSS) attacks via crafted essay feedback.

Related

Alias · CVE (1)

  • CVE-2015-0216 access.php in the Lesson module in Moodle 2.8.x before 2.8.2 does not set the RISK_XSS bit for graders, which allows remote authenticated… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References