GitHub Advisoryadvisory · Packagist
GHSA-2jrm-gww7-wch2 Moodle Arbitrary PHP code execution by site admins via Shibboleth configuration
HIGH
Official page ↗
- Aliases
- CVE-2021-20187
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-829, CWE-94
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.5, < 3.5.16 → fixed in 3.5.16
• Packagist moodle/moodle: >= 3.8, < 3.8.7 → fixed in 3.8.7
• Packagist moodle/moodle: >= 3.9, < 3.9.4 → fixed in 3.9.4
• Packagist moodle/moodle: >= 3.10, < 3.10.1 → fixed in 3.10.1
Description
It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.
Related
Alias · CVE (1)
- CVE-2021-20187 It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP… vulnerability