GitHub Advisoryadvisory · npm
GHSA-2m39-62fm-q8r3 Regular Expression Denial of Service in sshpk
HIGH
Official page ↗
- Aliases
- CVE-2018-3737
- Ecosystem
- npm
- Packages
- sshpk
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-185, CWE-770
- Reviewed
- 2020-06-16
Affected packages
• npm sshpk: < 1.13.2 → fixed in 1.13.2
Description
Versions of `sshpk` before 1.13.2 or 1.14.1 are vulnerable to regular expression denial of service when parsing crafted invalid public keys.
Recommendation
Update to version 1.13.2, 1.14.1 or later.
Related
Alias · CVE (1)
- CVE-2018-3737 sshpk is vulnerable to ReDoS when parsing crafted invalid public keys. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-3737 advisory
- https://github.com/joyent/node-sshpk/commit/46065d38a5e6d1bccf86d3efb2fb83c14e3f9957 web
- https://hackerone.com/reports/319593 web
- https://github.com/advisories/GHSA-2m39-62fm-q8r3 advisory
- https://github.com/joyent/node-sshpk/blob/v1.13.1/lib/formats/ssh.js#L17 web
- https://www.npmjs.com/advisories/606 web