GitHub Advisoryadvisory · npm

GHSA-2m3v-v2m8-q956 Denial of Service Vulnerability in React Server Components

HIGH Published 2025-12-11 Modified 2025-12-11 Official page ↗
Aliases
CVE-2025-55184
Ecosystem
npm
Packages
react-server-dom-parcel, react-server-dom-turbopack, react-server-dom-webpack
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400, CWE-502
Reviewed
2025-12-11

Affected packages

• npm react-server-dom-parcel: >= 19.0.0, < 19.0.2 → fixed in 19.0.2 • npm react-server-dom-turbopack: >= 19.0.0, < 19.0.2 → fixed in 19.0.2 • npm react-server-dom-webpack: >= 19.0.0, < 19.0.2 → fixed in 19.0.2 • npm react-server-dom-parcel: >= 19.1.0, < 19.1.3 → fixed in 19.1.3 • npm react-server-dom-parcel: >= 19.2.0, < 19.2.2 → fixed in 19.2.2 • npm react-server-dom-turbopack: >= 19.1.0, < 19.1.3 → fixed in 19.1.3 • npm react-server-dom-turbopack: >= 19.2.0, < 19.2.2 → fixed in 19.2.2 • npm react-server-dom-webpack: >= 19.1.0, < 19.1.3 → fixed in 19.1.3 • npm react-server-dom-webpack: >= 19.2.0, < 19.2.2 → fixed in 19.2.2

Description

Impact There is a denial of service vulnerability in React Server Components. React recommends updating immediately. The vulnerability exists in versions 19.0.0, 19.0.1 19.1.0, 19.1.1, 19.1.2, 19.2.0 and 19.2.1 of: • react-server-dom-webpack • react-server-dom-parcel • react-server-dom-turbopack These issues are present in the patches published last week. Patches Fixes were back ported to versions 19.0.2, 19.1.3, and 19.2.2. If you are using any of the above packages please upgrade to any of the fixed versions immediately. If your app’s React code does not use a server, your app is not affected by this vulnerability. If your app does not use a framework, bundler, or bundler plugin that supports React Server Components, your app is not affected by this vulnerability. References See the blog post for more information and upgrade instructions.

Related

Alias · CVE (1)

  • CVE-2025-55184 A pre-authentication denial of service vulnerability exists in React Server Components versions 19.0.0, 19.0.1 19.1.0, 19.1.1, 19.1.2,… vulnerability

Weakness · CWE (2)

  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-502 Deserialization of Untrusted Data weakness

References