GitHub Advisoryadvisory · npm
GHSA-2m5v-pch6-74hx undici vulnerable to TLS certificate validation bypass via dropped tls options in Agent
HIGH
Official page ↗
- Aliases
- CVE-2026-109383
- Ecosystem
- npm
- Packages
- undici
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-295
- Reviewed
- 2026-10-27
Affected packages
• npm undici: >= 4.0.0, < 6.29.1 → fixed in 6.29.1
• npm undici: >= 7.0.0, < 7.30.1 → fixed in 7.30.1
• npm undici: >= 8.0.0, < 8.12.2 → fixed in 8.12.2
Description
Impact
undici's `Agent` passes its constructor options through a JSON-based deep clone (`JSON.parse(JSON.stringify(...))`) before forwarding them to each per-origin `Pool`. JSON cannot represent functions, so a caller-supplied `tls` option containing a `checkServerIdentity` callback is silently dropped before it reaches the TLS layer. As a result, a TLS peer whose certificate a custom `checkServerIdentity` was written to reject, but which passes Node's default hostname and chain checks, is silently accepted when the request is made through `Agent`. Because `Agent` is the default dispatcher behind `request`, `fetch`, and `setGlobalDispatcher`, this is the path most applications use. `EnvHttpProxyAgent` is also affected on its direct and `NO_PROXY` routes, which delegate to an internal `Agent`.
Only applications that pass a function-valued `tls` option (such as a custom `checkServerIdentity` for certificate or public-key pinning) are affected. Passing the same options through `connect` is not affected. This is the `Agent` counterpart of the `BalancedPool` certificate validation bypass fixed in CVE-2026-84961.
Patches
Upgrade to undici `6.29.1`, `7.30.1`, or `8.12.2`. `Agent` now preserves the `tls` option outside the JSON clone, so custom TLS verification callbacks are forwarded to each origin unchanged.
Workarounds
Pass the TLS options through `connect` instead of `tls`. For proxied `EnvHttpProxyAgent` destinations, use `requestTls` / `proxyTls`.
Related
Alias · CVE (1)
- CVE-2026-109383 undici is an HTTP client library for Node.js. vulnerability
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://github.com/nodejs/undici/security/advisories/GHSA-2m5v-pch6-74hx web
- https://nvd.nist.gov/vuln/detail/CVE-2026-109383 advisory
- https://github.com/nodejs/undici/commit/04cb74b1db131ff8f5b4557dce811cbf5f4664b4 web
- https://github.com/nodejs/undici/commit/8c59f6b302898cb2e9b0f7962cd7212b6e597c9f web
- https://github.com/nodejs/undici/commit/f75eac00ac177f7b2e6c8bfbd52d4113164286e6 web
- https://cna.openjsf.org/security-advisories.html web
- https://github.com/nodejs/undici package
- https://github.com/nodejs/undici/releases/tag/v6.29.1 web
- https://github.com/nodejs/undici/releases/tag/v7.30.1 web
- https://github.com/nodejs/undici/releases/tag/v8.12.2 web