GitHub Advisoryadvisory · Packagist

GHSA-2mg9-hv69-897x Moodle Ability to delete glossary entries that belong to another glossary

MEDIUM Published 2022-05-24 Modified 2024-04-24 Official page ↗
Aliases
CVE-2019-10187
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-284, CWE-862
Reviewed
2024-04-24

Affected packages

• Packagist moodle/moodle: >= 3.7, < 3.7.1 → fixed in 3.7.1 • Packagist moodle/moodle: >= 3.6, < 3.6.5 → fixed in 3.6.5 • Packagist moodle/moodle: >= 3.5, < 3.5.7 → fixed in 3.5.7

Description

A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.

Related

Alias · CVE (1)

  • CVE-2019-10187 A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. vulnerability

Weakness · CWE (2)

  • CWE-284 Improper Access Control weakness
  • CWE-862 Missing Authorization weakness

References