GitHub Advisoryadvisory · Maven
GHSA-2mh9-wpgv-7xr8 Jenkins Cloud Foundry Plugin vulnerable to exposure of sensitive information
MEDIUM
Official page ↗
- Aliases
- CVE-2019-1003025
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:cloudfoundry
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-862
- Reviewed
- 2023-10-25
Affected packages
• Maven org.jenkins-ci.plugins:cloudfoundry: < 2.3.2 → fixed in 2.3.2
Description
\Jenkins Cloud Foundry Plugin did not perform permission checks on a method implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
Additionally, this form validation method did not require POST requests, resulting in a cross-site request forgery vulnerability.
This form validation method now requires POST requests and Overall/Administer (for global configuration) or Item/Configure permissions (for job configuration).
Related
Alias · CVE (1)
- CVE-2019-1003025 A exposure of sensitive information vulnerability exists in Jenkins Cloud Foundry Plugin 2.3.1 and earlier in… vulnerability
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-1003025 advisory
- https://github.com/jenkinsci/cloudfoundry-plugin/commit/61208697f60b91ad7f03a4dcec391b6d2115abca web
- https://jenkins.io/security/advisory/2019-02-19/#SECURITY-876 web
- https://web.archive.org/web/20200227084947/http://www.securityfocus.com/bid/107295 web