GitHub Advisoryadvisory · PyPI
GHSA-2mvc-557g-5638 pgAdmin is affected by a multi-factor authentication bypass vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2024-4215
- Ecosystem
- PyPI
- Packages
- pgadmin4
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
- Weaknesses
- CWE-89
- Reviewed
- 2024-05-03
Affected packages
• PyPI pgadmin4: < 8.6 → fixed in 8.6
Description
pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.
Related
Alias · CVE (1)
- CVE-2024-4215 pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-4215 advisory
- https://github.com/pgadmin-org/pgadmin4/issues/7425 web
- https://github.com/pgadmin-org/pgadmin4/commit/f4761f55f7cf6d56d6c5129f921393b0b47fd976 web
- https://github.com/pgadmin-org/pgadmin4 package
- https://lists.fedoraproject.org/archives/list/[email protected]/message/T2YFVCB4HCXU3FQBZ5XTWJZWSZUDNCXE web