GitHub Advisoryadvisory · RubyGems
GHSA-2p68-f74v-9wc6 ActiveSupport potentially unintended unmarshalling of user-provided objects in MemCacheStore and RedisCacheStore
CRITICAL
Official page ↗
- Aliases
- CVE-2020-8165
- Ecosystem
- RubyGems
- Packages
- activesupport
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2020-05-26
Affected packages
• RubyGems activesupport: >= 5.0.0, < 5.2.4.3 → fixed in 5.2.4.3
• RubyGems activesupport: >= 6.0.0, < 6.0.3.1 → fixed in 6.0.3.1
Description
In ActiveSupport, there is potentially unexpected behaviour in the MemCacheStore and RedisCacheStore where, when
untrusted user input is written to the cache store using the `raw: true` parameter, re-reading the result
from the cache can evaluate the user input as a Marshalled object instead of plain text. Vulnerable code looks like:
```
data = cache.fetch("demo", raw: true) { untrusted_string }
```
Versions Affected: rails = 5.2.4.3, rails >= 6.0.3.1
Impact
------
Unmarshalling of untrusted user input can have impact up to and including RCE. At a minimum,
this vulnerability allows an attacker to inject untrusted Ruby objects into a web application.
In addition to upgrading to the latest versions of Rails, developers should ensure that whenever
they are calling `Rails.cache.fetch` they are using consistent values of the `raw` parameter for both
reading and writing, especially in the case of the RedisCacheStore which does not, prior to these changes,
detect if data was serialized using the raw option upon deserialization.
Workarounds
-----------
It is recommended that application developers apply the suggested patch or upgrade to the latest release as
soon as possible. If this is not possible, we recommend ensuring that all user-provided strings cached using
the `raw` argument should be double-checked to ensure that they conform to the expected format.
Related
Alias · CVE (1)
- CVE-2020-8165 A deserialization of untrusted data vulnernerability exists in rails < 5.2.4.3, rails < 6.0.3.1 that can allow an attacker to unmarshal… vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-8165 advisory
- https://hackerone.com/reports/413388 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activesupport/CVE-2020-8165.yml web
- https://groups.google.com/forum/#!topic/rubyonrails-security/bv6fW4S0Y1c web
- https://groups.google.com/g/rubyonrails-security/c/bv6fW4S0Y1c web
- https://lists.debian.org/debian-lts-announce/2020/06/msg00022.html web
- https://lists.debian.org/debian-lts-announce/2020/07/msg00013.html web
- https://security.netapp.com/advisory/ntap-20250509-0002 web
- https://weblog.rubyonrails.org/2020/5/18/Rails-5-2-4-3-and-6-0-3-1-have-been-released web
- https://www.debian.org/security/2020/dsa-4766 web
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00031.html web
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00034.html web