GitHub Advisoryadvisory · PyPI

GHSA-2p78-8hh6-96xc feedparser Cross-site Scripting vulnerability

MEDIUM Published 2018-07-23 Modified 2024-09-20 Official page ↗
Aliases
CVE-2011-1157
Ecosystem
PyPI
Packages
feedparser
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• PyPI feedparser: >= 5.0, < 5.0.1 → fixed in 5.0.1

Description

Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) 5.x before 5.0.1 allows remote attackers to inject arbitrary web script or HTML via malformed XML comments.

Related

Alias · CVE (1)

  • CVE-2011-1157 Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) 5.x before 5.0.1… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References