GitHub Advisoryadvisory · PyPI

GHSA-2pfh-q76x-gwvm Improper Input Validation and Command Injection in Ansible

HIGH Published 2021-09-23 Modified 2024-09-06 Official page ↗
Aliases
CVE-2021-3583
Ecosystem
PyPI
Packages
ansible
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-20, CWE-77, CWE-94
Reviewed
2021-09-23

Affected packages

• PyPI ansible: < 2.9.23rc1 → fixed in 2.9.23rc1 • PyPI ansible: >= 2.10.0a1, < 2.10.11rc1 → fixed in 2.10.11rc1 • PyPI ansible: >= 2.11.0a1, < 2.11.2rc1 → fixed in 2.11.2rc1

Description

A flaw was found in Ansible, where a user's controller is vulnerable to template injection. This issue can occur through facts used in the template if the user is trying to put templates in multi-line YAML strings and the facts being handled do not routinely include special template characters. This flaw allows attackers to perform command injection, which discloses sensitive information. The highest threat from this vulnerability is to confidentiality and integrity.

Related

Alias · CVE (1)

  • CVE-2021-3583 A flaw was found in Ansible, where a user's controller is vulnerable to template injection. vulnerability

Weakness · CWE (3)

  • CWE-20 Improper Input Validation weakness
  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness
  • CWE-94 Improper Control of Generation of Code weakness

References