GitHub Advisoryadvisory · Maven
GHSA-2pp9-r4rv-6p6j Exposure of Sensitive Information to an Unauthorized Actor in Jenkins
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1999006
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2022-06-28
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 2.121.2 → fixed in 2.121.2
• Maven org.jenkins-ci.main:jenkins-core: >= 2.122, < 2.132 → fixed in 2.132
Description
A exposure of sensitive information vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in Plugin.java that allows attackers to determine the date and time when a plugin HPI/JPI file was last extracted, which typically is the date of the most recent installation/upgrade.
Related
Alias · CVE (1)
- CVE-2018-1999006 A exposure of sensitive information vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in Plugin.java that allows… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness