GitHub Advisoryadvisory · Packagist

GHSA-2pq5-gpqf-g4r3 Magento has a file extension restrictions bypass

CRITICAL Published 2022-05-24 Modified 2025-11-07 Official page ↗
Aliases
CVE-2021-36040
Ecosystem
Packagist
Packages
magento/project-community-edition, magento/community-edition
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2025-11-07

Affected packages

• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet) • Packagist magento/community-edition: 2.4.2 (no fix yet) • Packagist magento/community-edition: >= 2.4.2-p1, < 2.4.2-p2 → fixed in 2.4.2-p2 • Packagist magento/community-edition: 2.3.7 (no fix yet) • Packagist magento/community-edition: < 2.3.7-p1 → fixed in 2.3.7-p1

Description

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability. An attacker with admin privileges can upload a specially crafted file to bypass file extension restrictions and could lead to remote code execution.

Related

Alias · CVE (1)

  • CVE-2021-36040 Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References