GitHub Advisoryadvisory · Packagist

GHSA-2q79-56rq-8v3c Codiad information disclosure vulnerability

HIGH Published 2023-02-21 Modified 2023-03-03 Official page ↗
Aliases
CVE-2017-20178
Ecosystem
Packagist
Packages
codiad/codiad
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-200
Reviewed
2023-03-03

Affected packages

• Packagist codiad/codiad: < 2.8.1 → fixed in 2.8.1

Description

A vulnerability was found in Codiad 2.8.0. It has been rated as problematic. Affected by this issue is the function saveJSON of the file components/install/process.php. The manipulation of the argument data leads to information disclosure. The attack may be launched remotely. Upgrading to version 2.8.1 is able to address this issue. The name of the patch is 517119de673e62547ee472a730be0604f44342b5. It is recommended to upgrade the affected component. VDB-221498 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Related

Alias · CVE (1)

  • CVE-2017-20178 ** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in Codiad 2.8.0. vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References