GitHub Advisoryadvisory · PyPI

GHSA-2qfp-q593-8484 Scrapy is vulnerable to a denial of service (DoS) attack due to flaws in brotli decompression implementation

HIGH Published 2025-10-31 Modified 2025-11-17 Official page ↗
Aliases
CVE-2025-6176
Ecosystem
PyPI
Packages
brotli, Scrapy
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2025-10-31

Affected packages

• PyPI brotli: < 1.2.0 → fixed in 1.2.0 • PyPI Scrapy: < 2.13.4 → fixed in 2.13.4

Description

Scrapy versions up to 2.13.3 are vulnerable to a denial of service (DoS) attack due to a flaw in its brotli decompression implementation. The protection mechanism against decompression bombs fails to mitigate the brotli variant, allowing remote servers to crash clients with less than 80GB of available memory. This occurs because brotli can achieve extremely high compression ratios for zero-filled data, leading to excessive memory consumption during decompression. Mitigation for this vulnerability needs security enhancement added in brotli v1.2.0.

Related

Alias · CVE (1)

  • CVE-2025-6176 Scrapy versions up to 2.13.2 are vulnerable to a denial of service (DoS) attack due to a flaw in its brotli decompression implementation. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References