GitHub Advisoryadvisory · PyPI

GHSA-2qmj-7962-cjq8 langchain arbitrary code execution vulnerability

CRITICAL Published 2023-07-03 Modified 2024-11-22 Official page ↗
Aliases
CVE-2023-36258
Ecosystem
PyPI
Packages
langchain
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2023-07-06

Affected packages

• PyPI langchain: < 0.0.247 → fixed in 0.0.247

Description

An issue in langchain allows an attacker to execute arbitrary code via the PALChain in the python exec method.

Related

Alias · CVE (1)

  • CVE-2023-36258 An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because Python code with os.system, exec, or eval can be… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References