GitHub Advisoryadvisory · Packagist
GHSA-2qph-q8xw-gv7q Drupal Core Improperly Controlled Modification of Dynamically-Determined Object Attributes Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2025-31674
- Ecosystem
- Packagist
- Packages
- drupal/core
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
- Weaknesses
- CWE-913, CWE-915
- Reviewed
- 2025-04-01
Affected packages
• Packagist drupal/core: >= 8.0.0, < 10.3.13 → fixed in 10.3.13
• Packagist drupal/core: >= 10.4.0, < 10.4.3 → fixed in 10.4.3
• Packagist drupal/core: >= 11.0.0, < 11.0.12 → fixed in 11.0.12
• Packagist drupal/core: >= 11.1.0, < 11.1.3 → fixed in 11.1.3
Description
Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection.This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.
Related
Alias · CVE (1)
- CVE-2025-31674 Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object… vulnerability