GitHub Advisoryadvisory · Packagist

GHSA-2qr8-h6pq-m27v Piwik (now Matomo) Vulnerable to Arbitrary Code Execution

MEDIUM Published 2022-05-13 Modified 2025-04-12 Official page ↗
Aliases
CVE-2011-4941
Ecosystem
Packagist
Packages
piwik/piwik, matomo/matomo
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Weaknesses
CWE-269
Reviewed
2025-04-12

Affected packages

• Packagist piwik/piwik: >= 1.2, < 1.5 → fixed in 1.5 • Packagist matomo/matomo: >= 1.2, < 1.5 → fixed in 1.5

Description

Unspecified vulnerability in Piwik 1.2 through 1.4 allows remote attackers with the view permission to execute arbitrary code via unknown attack vectors.

Related

Alias · CVE (1)

  • CVE-2011-4941 Unspecified vulnerability in Piwik 1.2 through 1.4 allows remote attackers with the view permission to execute arbitrary code via unknown… vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References