GitHub Advisoryadvisory · Maven

GHSA-2r4x-667f-mpfh Apache Seata Vulnerable to Deserialization of Untrusted Data

LOW Published 2025-03-20 Modified 2026-03-27 Official page ↗
Aliases
CVE-2024-47552
Ecosystem
Maven
Packages
org.apache.seata:seata-config-core
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U
Weaknesses
CWE-502
Reviewed
2025-03-20

Affected packages

• Maven org.apache.seata:seata-config-core: >= 2.0.0, < 2.2.0 → fixed in 2.2.0

Description

Deserialization of Untrusted Data vulnerability in Apache Seata (incubating). This issue affects Apache Seata (incubating): from 2.0.0 before 2.2.0. Users are recommended to upgrade to version 2.2.0, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2024-47552 Deserialization of Untrusted Data vulnerability in Apache Seata (incubating). vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References