GitHub Advisoryadvisory · Packagist

GHSA-2r5h-6r7v-5m7c Symphony Vulnerable to PHP Code Injection via YAML Parsing

HIGH Published 2022-05-17 Modified 2024-04-25 Official page ↗
Aliases
CVE-2013-1348
Ecosystem
Packagist
Packages
symfony/symfony, symfony/yaml
Severity
High
Weaknesses
CWE-94
Reviewed
2024-04-25

Affected packages

• Packagist symfony/symfony: >= 2.0.0, < 2.0.22 → fixed in 2.0.22 • Packagist symfony/yaml: >= 2.0.0, < 2.0.22 → fixed in 2.0.22

Description

The `Yaml::parse` function in Symfony 2.0.x before 2.0.22 remote attackers to execute arbitrary PHP code via a PHP file, a different vulnerability than CVE-2013-1397.

Related

Alias · CVE (1)

  • CVE-2013-1348 The Yaml::parse function in Symfony 2.0.x before 2.0.22 remote attackers to execute arbitrary PHP code via a PHP file, a different… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References