GitHub Advisoryadvisory · npm
GHSA-2r7f-4h2c-5x73 fury-adapter-swagger allows arbitrary file read from system
HIGH
Official page ↗
- Aliases
- CVE-2016-1000249
- Ecosystem
- npm
- Packages
- fury-adapter-swagger
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-22
- Reviewed
- 2020-08-31
Affected packages
• npm fury-adapter-swagger: >= 0.2.0, < 0.9.7 → fixed in 0.9.7
Description
`fury-adapter-swagger` from version 0.2.0 until version 0.9.7 has a weakness that allows an attacker to read arbitrary files off of the system. This can be used to read sensitive data, or to cause a denial of service condition by attempting to read something like `/dev/zero`.
Proof of Concept:
```yaml
---
swagger: '2.0'
info:
title: Read local files
version: '1.0'
paths:
/foo:
get:
responses:
200:
description: Some description
examples:
text/html:
example:
$ref: '/etc/passwd'
```
Recommendation
Upgrade to version 0.9.7 or later.
Related
Alias · not in database (1)
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://github.com/apiaryio/fury-adapter-swagger/pull/89 web
- https://github.com/apiaryio/fury-adapter-swagger/commit/777e2d68f03546a88f3203bbd4725df8b1f662a7 web
- https://github.com/apiaryio/fury-adapter-swagger/commit/f4407e3a5323bc31123d45dbc93b8417002e4d51#diff-54c345dc104dc19440f9c2482b7883df820e8b9b699fdd8fa07e2773e7197a29 web
- https://github.com/apiaryio/fury-adapter-swagger package
- https://security.snyk.io/vuln/npm:fury-adapter-swagger:20161024 web
- https://www.npmjs.com/advisories/305 web