GitHub Advisoryadvisory · Packagist
GHSA-2r94-wm5v-4prx Magento does not properly protect credentials
LOW
Official page ↗
- Aliases
- CVE-2025-27192
- Ecosystem
- Packagist
- Packages
- magento/project-community-edition, magento/community-edition
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-522
- Reviewed
- 2025-10-23
Affected packages
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p5 → fixed in 2.4.7-p5
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p10 → fixed in 2.4.6-p10
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p12 → fixed in 2.4.5-p12
• Packagist magento/community-edition: < 2.4.4-p13 → fixed in 2.4.4-p13
• Packagist magento/community-edition: >= 2.4.8-beta1, < 2.4.8-beta2 → fixed in 2.4.8-beta2
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.4 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.7 (no fix yet)
Description
Magento versions 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12, 2.4.8-beta2 and earlier are affected by an Insufficiently Protected Credentials vulnerability that could lead to a security feature bypass. A high privileged attacker could exploit this vulnerability to gain unauthorized access to protected resources by obtaining sensitive credential information. Exploitation of this issue does not require user interaction.
Related
Alias · CVE (1)
- CVE-2025-27192 Adobe Commerce versions 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12, 2.4.8-beta2 and earlier are affected by an Insufficiently Protected… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness