GitHub Advisoryadvisory · Packagist
GHSA-2r9m-wg35-rfvc Moodle vulnerable to cache poisoning via injection into storage
MEDIUM
Official page ↗
- Aliases
- CVE-2024-43428
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-345, CWE-74
- Reviewed
- 2024-11-07
Affected packages
• Packagist moodle/moodle: < 4.1.12 → fixed in 4.1.12
• Packagist moodle/moodle: >= 4.2.0-beta, < 4.2.9 → fixed in 4.2.9
• Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.6 → fixed in 4.3.6
• Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.2 → fixed in 4.4.2
Description
To address a cache poisoning risk in Moodle, additional validation for local storage was required.
Related
Alias · CVE (1)
- CVE-2024-43428 To address a cache poisoning risk in Moodle, additional validation for local storage was required. vulnerability