GitHub Advisoryadvisory · Packagist
GHSA-2rc5-2755-v422 Mautic vulnerable to stored cross-site scripting in description field
HIGH
Official page ↗
- Aliases
- CVE-2021-27915
- Ecosystem
- Packagist
- Packages
- mautic/core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
- Weaknesses
- CWE-79, CWE-80
- Reviewed
- 2024-04-11
Affected packages
• Packagist mautic/core: >= 1.0.0-beta2, < 4.4.12 → fixed in 4.4.12
Description
Impact
Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions.
This could lead to the user having elevated access to the system.
Patches
Update to 4.4.12
Workarounds
None
References
• https://owasp.org/www-project-top-ten/2017/A7_2017-Cross-Site_Scripting_(XSS)
• https://owasp.org/www-project-web-security-testing-guide/latest/4-Web_Application_Security_Testing/07-Input_Validation_Testing/02-Testing_for_Stored_Cross_Site_Scripting
If you have any questions or comments about this advisory:
Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2021-27915 Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be… vulnerability