GitHub Advisoryadvisory · PyPI

GHSA-2rhq-96q8-4vjq LlamaIndex vulnerable to Path Traversal attack through its encode_image function

HIGH Published 2025-07-07 Modified 2025-07-08 Official page ↗
Aliases
CVE-2025-6209
Ecosystem
PyPI
Packages
llama-index-core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-29
Reviewed
2025-07-08

Affected packages

• PyPI llama-index-core: >= 0.11.23, < 0.12.41 → fixed in 0.12.41

Description

A path traversal vulnerability exists in run-llama/llama_index versions 0.11.23 through 0.12.40, specifically within the `encode_image` function in `generic_utils.py`. This vulnerability allows an attacker to manipulate the `image_path` input to read arbitrary files on the server, including sensitive system files. The issue arises due to improper validation or sanitization of the file path, enabling path traversal sequences to access files outside the intended directory. The vulnerability is fixed in version 0.12.41.

Related

Alias · CVE (1)

  • CVE-2025-6209 A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the `encode_image`… vulnerability

Weakness · CWE (1)

  • CWE-29 Path Traversal: '\..\filename' weakness

References