GitHub Advisoryadvisory · Packagist
GHSA-2rm7-xxx8-35jh MediaWiki Cross-site Scripting (XSS)
MEDIUM
Official page ↗
- Aliases
- CVE-2019-12471
- Ecosystem
- Packagist
- Packages
- mediawiki/core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-15
Affected packages
• Packagist mediawiki/core: >= 1.27.0, < 1.27.6 → fixed in 1.27.6
• Packagist mediawiki/core: >= 1.30.0, < 1.30.2 → fixed in 1.30.2
• Packagist mediawiki/core: >= 1.31.0, < 1.31.2 → fixed in 1.31.2
Description
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Related
Alias · CVE (1)
- CVE-2019-12471 Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-12471 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12471.yaml web
- https://github.com/wikimedia/mediawiki package
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html web
- https://phabricator.wikimedia.org/T207603 web
- https://seclists.org/bugtraq/2019/Jun/12 web
- https://www.debian.org/security/2019/dsa-4460 web