GitHub Advisoryadvisory · Go
GHSA-2v3w-6g35-5f9v Mattermost fails to properly validate User-Agent header tokens
MEDIUM
Official page ↗
- Aliases
- CVE-2026-25783
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-1287
- Reviewed
- 2026-03-17
Affected packages
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20260129181235-1346cf529aef → fixed in 8.0.0-20260129181235-1346cf529aef
• Go github.com/mattermost/mattermost-server: < 5.3.2-0.20260129181235-1346cf529aef → fixed in 5.3.2-0.20260129181235-1346cf529aef
• Go github.com/mattermost/mattermost-server: >= 10.11.0-rc1, < 10.11.11 → fixed in 10.11.11
• Go github.com/mattermost/mattermost-server: >= 11.2.0-rc1, < 11.2.3 → fixed in 11.2.3
• Go github.com/mattermost/mattermost-server: >= 11.3.0-rc1, < 11.3.1 → fixed in 11.3.1
Description
Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to properly validate User-Agent header tokens which allows an authenticated attacker to cause a request panic via a specially crafted User-Agent header. Mattermost Advisory ID: MMSA-2026-00586
Related
Alias · CVE (1)
- CVE-2026-25783 Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to properly validate User-Agent header tokens which allows… vulnerability
Weakness · CWE (1)
- CWE-1287 Improper Validation of Specified Type of Input weakness