GitHub Advisoryadvisory · Packagist
GHSA-2v82-5746-vwqc XSS in doc_link
HIGH
Official page ↗
- Aliases
- CVE-2021-29625
- Ecosystem
- Packagist
- Packages
- vrana/adminer
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2021-05-17
Affected packages
• Packagist vrana/adminer: >= 4.7.8, < 4.8.1 → fixed in 4.8.1
Description
Impact
Users of MySQL, MariaDB, PgSQL and SQLite are affected. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected.
Patches
Patched by 4043092, included in version 4.8.1.
Workarounds
Do both:
• Use browser supporting strict CSP.
• Enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).
References
https://sourceforge.net/p/adminer/bugs-and-features/797/
For more information
If you have any questions or comments about this advisory:
• Comment at 4043092.
Related
Alias · CVE (1)
- CVE-2021-29625 Adminer is open-source database management software. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/vrana/adminer/security/advisories/GHSA-2v82-5746-vwqc web
- https://nvd.nist.gov/vuln/detail/CVE-2021-29625 advisory
- https://github.com/vrana/adminer/commit/4043092ec2c0de2258d60a99d0c5958637d051a7 web
- https://packagist.org/packages/vrana/adminer web
- https://sourceforge.net/p/adminer/bugs-and-features/797 web