GitHub Advisoryadvisory · Packagist

GHSA-2vh3-cj9j-mcj5 eZ Publish Legacy Cross-site Scripting (XSS) in 'disabled module' error template

MEDIUM Published 2024-05-15 Modified 2024-05-15 Official page ↗
Ecosystem
Packagist
Packages
ezsystems/ezpublish-legacy
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2024-05-15

Affected packages

• Packagist ezsystems/ezpublish-legacy: >= 2018.9.0, < 2018.9.1.2 → fixed in 2018.9.1.2 • Packagist ezsystems/ezpublish-legacy: >= 2018.6.0, < 2018.6.1.3 → fixed in 2018.6.1.3 • Packagist ezsystems/ezpublish-legacy: >= 2011.0.0, < 2017.12.4.2 → fixed in 2017.12.4.2 • Packagist ezsystems/ezpublish-legacy: >= 5.4.0, < 5.4.12.2 → fixed in 5.4.12.2 • Packagist ezsystems/ezpublish-legacy: >= 5.3.0, < 5.3.12.5 → fixed in 5.3.12.5

Description

This security advisory fixes a vulnerability in eZ Publish Legacy, and we recommend that you install it as soon as possible if you are using Legacy via the LegacyBridge. Installations where all modules are disabled may be vulnerable to XSS injection in the module name. This is a rare configuration, but we still recommend installing the update, which adds the necessary input washing. To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-legacy/commit/4697bff700e8cf95d5847ea19dad3479a77b02d9

Related

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References