GitHub Advisoryadvisory · Packagist

GHSA-2vhr-4mhq-m35c Moodle does not properly restrict access

MEDIUM Published 2022-05-13 Modified 2024-01-23 Official page ↗
Aliases
CVE-2014-0123
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-23

Affected packages

• Packagist moodle/moodle: < 2.4.9 → fixed in 2.4.9 • Packagist moodle/moodle: >= 2.5.0, < 2.5.5 → fixed in 2.5.5 • Packagist moodle/moodle: >= 2.6.0, < 2.6.2 → fixed in 2.6.2

Description

The wiki subsystem in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 does not properly restrict (1) view and (2) edit access, which allows remote authenticated users to perform wiki operations by leveraging the student role and using the Recent Activity block to reach the individual wiki of an arbitrary student.

Related

Alias · CVE (1)

  • CVE-2014-0123 The wiki subsystem in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 does not properly restrict (1)… vulnerability

References